Hello and welcome to Packard Motor Car Information! If you're new here, please register for a free account.  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
FAQ's
Main Menu
Recent Forum Topics
Who is Online
110 user(s) are online (67 user(s) are browsing Forums)

Members: 2
Guests: 108

Packardbarry, Alvin14, more...
Helping out...
PackardInfo is a free resource for Packard Owners that is completely supported by user donations. If you can help out, that would be great!

Donate via PayPal
Video Content
Visit PackardInfo.com YouTube Playlist

Donate via PayPal




Ignition switch position and oil/gen lights
#1
Just can't stay away
Just can't stay away

Craig Fox
See User information
I have a 1951 model 200 that I have been sorting out. I have driven about 500 miles since I have acquired her, and this is something new. When I first got her the ignition switch showed no lights on off, or accessory. The other day it showed oil and gen on on, gen on off, and gen on accessory. So I disconnected the battery overnight. The next day it was back to oil/gen on, on only again. I drove around a bit and now I get oil/gen on, on, and on accessory, but nothing on off. I suspect the ignition switch. Any ideas? Car starts and runs fine on the on position. Engine turned over on accessory, but doesn't start.

Posted on: 2015/9/6 14:13
 Top  Print 
 


Re: Ignition switch position and oil/gen lights
#2
Forum Ambassador
Forum Ambassador

HH56
See User information
It could be the switch but before condemning it check the back and make sure none of the wires or terminals on the GA post is oriented so vibration could cause it to touch the battery feed on the AM post which is very close to GA. If the loom is the old fabric and rubber stuff it could also have a chunk of insulation off somewhere allowing wires to touch.

If the switch is mounted in the normal position with the bulb on top, looking from the back GA is the long post about 11:00 and AM will be about 1:00. COIL is the remaining post at about 7:00.

When the key is off there should be no power on anything except AM. GA gets power in both run (on) or acc position and you can crank the engine (no starting) in acc position. Since there is a single feed from GA spliced to both lamp sockets you should have the BAT and OIL lights in both positions. COIL gets power only in the run (on) position. Typically only the coil is fed off that post and lets you start the car when the key is in the run position only.

Posted on: 2015/9/6 14:58
Howard
 Top  Print 
 








Search
Recent Photos
Photo of the Day
1939 PACKARD ADVERT
Recent Registry
Website Comments or Questions?? Click Here Copyright 2006-2021, PackardInfo.com All Rights Reserved