Merry Christmas and welcome to Packard Motor Car Information! If you're new here, please register for a free account.  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
FAQ's
Main Menu
Recent Forum Topics
Who is Online
47 user(s) are online (31 user(s) are browsing Forums)

Members: 0
Guests: 47

more...
Helping out...
PackardInfo is a free resource for Packard Owners that is completely supported by user donations. If you can help out, that would be great!

Donate via PayPal
Video Content
Visit PackardInfo.com YouTube Playlist

Donate via PayPal



« 1 ... 39 40 41 (42) 43 44 45 »

Re: 51Packards....52 Packard 200 Deluxe!
Forum Ambassador
Forum Ambassador

HH56
See User information
Two easy things to check. First is the level in the radiator. Packard states that 1" below the bottom (pressure sealing lip) of the fill neck is the correct level. The other is the pressure cap. A long reach type for radiators before 55 and make sure it is in good condition. A problem with either item and it spits coolant out the overflow.

Posted on: 2018/8/1 18:42
Howard
 Top  Print 
 


Re: 51Packards....52 Packard 200 Deluxe!
Home away from home
Home away from home

Charles
See User information
Thanks Howard,

The last two times were the first time the car had done that since I owned it. Each time pretty much all of the coolant left the radiator. I couldn't tell if it was just the overflow or from somewhere else. I put in 1-1/2 gallons and it appears about 1" below the fill neck. I'm going to order this https://www.napaonline.com/en/p/BK_7031411?ref=MA== it's the radiator cap BigKev has listed in the parts X-Ref.

Posted on: 2018/8/1 18:52
[url=h
 Top  Print 
 


Re: 51Packards....52 Packard 200 Deluxe!
Forum Ambassador
Forum Ambassador

HH56
See User information
That Napa cap Kev crossed looks correct. Here is the pre 55 long cap on the left and modern on the right. MM dimensions are from the inside of the cap to sealing surface so with the given Napa dimensions for the overall cap height it should be the correct long reach type.

Attach file:



jpg  (36.34 KB)
209_5b624f5ab6fb1.jpg 997X482 px

Posted on: 2018/8/1 19:25
Howard
 Top  Print 
 


Re: 51Packards....52 Packard 200 Deluxe!
Home away from home
Home away from home

Charles
See User information
Awesome! Thanks again! Fingers crossed this is the fix. Ran the car another 1/2 hour today and still did not get into the middle or boil over. Seems the phenomenon only happens if the car is driven. Maybe the pressure gets too high at the sustained higher rpms and the cap can't hold it. I'll have to take it for a test drive when the cap comes in.

Posted on: 2018/8/1 19:41
[url=h
 Top  Print 
 


Re: 51Packards....52 Packard 200 Deluxe!
Home away from home
Home away from home

Charles
See User information
8-21-18

I installed the oil sender recommended by Howard in a previous post. It fit perfectly. I couldn't test it because I didn't have any gas. Seems like it will work though.

Opened up the gauge cluster to get at the speedometer cable. Found the end broken about 3" from the end. I crawled under the car and disconnected the cable from the trans. Pulled the gear and that came out as well. That end of the cable was also broken!

I'm going to try the universal repair kits I read about. I went to Autozone and the only one they had was missing the tips.

Went to O'Reilly's and had to go through the Make and Model questioning. Got the "OK and who made Packard?" question! That amused me but I was getting frustrated. They ordered the part based on the Autozone part number and it will arrive tomorrow. Fingers crossed it works.

I also prepped a replacement speedometer I had bought by putting oil in the felt hole and bushing. Between the cable and the speedo I hope to have a reliable system

I'm also planning on taking the thermostat housing from my spare motor and putting it in this car to get it to heat up faster (assuming no thermostat in current car).

Attach file:



jpg  (15.51 KB)
508_5b7caf02cc231.jpg 400X400 px

Posted on: 2018/8/21 19:32
[url=h
 Top  Print 
 


Re: 51Packards....52 Packard 200 Deluxe!
Home away from home
Home away from home

Charles
See User information
8-22-18

I installed the replacement speedometer (and lowered my the car's mileage by 15,000 miles!).

The new speedometer cable core went in pretty simply except the square end that you attach to the cable was longer than the original. I had to cut it with the cut off tool to get it to fit. Put plenty of graphite powder on the core as I slid it into the outer cable.

Started the car and the oil light is working perfectly! I added the sender info Howard gave me to the parts X-Ref.

It will be a while before I can get the car on the road and test the speedo and if any antifreeze is going to come out.

Posted on: 2018/8/22 20:35
[url=h
 Top  Print 
 


Re: 51Packards....52 Packard 200 Deluxe!
Home away from home
Home away from home

Charles
See User information
8-29-18

Had a great day today! Took the car out and nothing came out of the radiator! Oil light stayed off like it should and the speedometer appears to be working well. I only drove around the neighborhood, but long enough for the car to be warmed up. The temp gauge only went to the far right of the C. I still have to check if there is a thermostat in it. The idle is kind of high so I'll have to adjust that. Next trip will be longer and farther.

Posted on: 2018/8/29 18:17
[url=h
 Top  Print 
 


Re: 51Packards....52 Packard 200 Deluxe!
Home away from home
Home away from home

Charles
See User information
10-25-18

This driving season has really blown by. Not being home almost every weekend and not having much time after work has put the car on hold.

The radiator has mostly water so after work today I drained it out to replace with water/antifreeze before winter. While it was drained, I took the thermostat housing off and as I predicted, there was no thermostat. Took the one out of the '51 (was brand new) and filled the radiator at least half way. I have to buy more antifreeze before I can see if it warms up properly now.

Posted on: 2018/10/25 17:51
[url=h
 Top  Print 
 


Re: 51Packards....52 Packard 200 Deluxe!
Home away from home
Home away from home

John
See User information
Driving season has returned!! John

Posted on: 2019/4/10 20:05
 Top  Print 
 


Re: 51Packards....52 Packard 200 Deluxe!
Home away from home
Home away from home

Charles
See User information
7/25/19

No driving this whole year so far. Car will not turn over. Due to a series of unfortunate events, my time has been taken over with boat and multiple car repairs involving body damage keeping me from really looking at the car at all. I'm at the point now where I need to get the Packard running to move it out of the way of another car I have to fix. The battery is fully charged according to my charger. When I press the gas pedal or jump the starter to motor posts, the car only clicks. I think it's tripping a breaker. After the click no more bat or oil light on the dash. I have to disconnect and reconnect the battery to get them to turn on again. Maybe there is a short somewhere or the starter is not working. I don't think there is anyone around me that can test the starter. It was rebuilt in 1998ish, with very few miles on it since then. Worst case I'll have to pull the car out until I figure it out.

Posted on: 2019/7/25 19:54
[url=h
 Top  Print 
 




« 1 ... 39 40 41 (42) 43 44 45 »




Search
Recent Photos
Photo of the Day
1936 PACKARD 120 EIGHT 5-PASS TOURING SEDAN
Recent Registry
Website Comments or Questions?? Click Here Copyright 2006-2021, PackardInfo.com All Rights Reserved