Hello and welcome to Packard Motor Car Information! If you're new here, please register for a free account.  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
FAQ's
Main Menu
Recent Forum Topics
Who is Online
45 user(s) are online (35 user(s) are browsing Forums)

Members: 0
Guests: 45

more...
Helping out...
PackardInfo is a free resource for Packard Owners that is completely supported by user donations. If you can help out, that would be great!

Donate via PayPal
Video Content
Visit PackardInfo.com YouTube Playlist

Donate via PayPal




Brake problem
#1
Quite a regular
Quite a regular

smashburn
See User information
Hello everyone. So I bought a refurbished power brake about 3 months ago and hooked it up, bled the lines and it worked fine. The car sat for 3 months while we did some engine work and today when I put it in gear the brake was stuck. The engine just started running after sitting for years and it just now got vacuum. Any thoughts? I'm going to bleed the breaks again and see if that fixes it but could it possibly be a bad bendix refurb unit?

Posted on: 2015/8/7 15:43
 Top  Print 
 


Re: Brake problem
#2
Forum Ambassador
Forum Ambassador

Owen_Dyneto
See User information
Quite a few other possibilities to check out and eliminate before I'd suspect a new PB unit.

Posted on: 2015/8/7 16:10
 Top  Print 
 








Search
Recent Photos
Photo of the Day
1917 PACKARD ADVERT-B&W
Recent Registry
Website Comments or Questions?? Click Here Copyright 2006-2021, PackardInfo.com All Rights Reserved