Hello and welcome to Packard Motor Car Information! If you're new here, please register for a free account.  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
FAQ's
Main Menu
Recent Forum Topics
Who is Online
68 user(s) are online (46 user(s) are browsing Forums)

Members: 6
Guests: 62

Packard Joe, kevinpackard, Tim Stockwell, Ozstatman, HH56, Packard 1948, more...
Helping out...
PackardInfo is a free resource for Packard Owners that is completely supported by user donations. If you can help out, that would be great!

Donate via PayPal



« 1 ... 3 4 5 (6)

Re: 1954 Packard Pacific | Sparks-Withington Sparton Sparco 6 volt Horn | low sound
#51
Forum Ambassador
Forum Ambassador

HH56
See User information
Probably about the only 6v horns you find will be used on ebay or from someone here with a parts car. Not sure how loud a boat horn might be in comparison but Packards were no slouch in the noise department.

It might be low voltage so a couple of possibilities maybe worth looking into are dirty connections at one of the terminals or dirty or pitted contacts in the relay or in the horns themselves.

You can bend the tabs to take the case off the relay and clean the contacts with a point burnisher or emery cloth or just replace it with a new universal 6v horn relay.

The dome covers on the horns just pop off. There is a small slot where you insert a screwdriver and twist to force the cover rim over some small retaining bumps. Once off look for any rust and corrosion on the diaphragm and around the pitch adjustment screw. A build up will keep the diaphragm from moving in a full range. There are a set of contacts in each horn that could probably stand a cleaning. You could also check carefully for any wasp or insect nests built in the opening or down inside the air chambers that could be muffling the sound.

Posted on: 9/17 12:38
Howard
 Top  Print 
 


Re: 1954 Packard Pacific | Sparks-Withington Sparton Sparco 6 volt Horn | low sound
#52
Just can't stay away
Just can't stay away

54packpac
See User information
Great, thank you Howard. I'm on it. TC

Posted on: 9/20 10:06
 Top  Print 
 


Re: 1954 Packard Pacific | Sparks-Withington Sparton Sparco 6 volt Horn | low sound
#53
Forum Ambassador
Forum Ambassador

HH56
See User information
Assuming the car currently has the stock 6v, another thought is if the car had ever been run on 12v a pair of 12v horns could have been installed. Not easy to tell apart but those would definitely sound weak if run on 6v.

Posted on: 9/20 10:28
Howard
 Top  Print 
 


Re: 1954 Packard Pacific | Sparks-Withington Sparton Sparco 6 volt Horn | low sound
#54
Just can't stay away
Just can't stay away

54packpac
See User information
Hi Howard,

I burnished the the tabs and put a new 6 volt Napa HR100 relay on. That seems to have done the trick unless my ears are playing tricks on me. Thank you for your help.

TC

Attach file:



jpg  1954packnaprhr100a.JPG (70.77 KB)
201206_6151cf71a285e.jpg 749X676 px

jpg  1954packnapaHR100.JPG (116.96 KB)
201206_6151cf7b499ad.jpg 1504X870 px

Posted on: 9/27 9:04
 Top  Print 
 




« 1 ... 3 4 5 (6)




Search
Recent Photos
Photo of the Day
panther daytona
Recent Registry
Website Comments or Questions?? Click Here Copyright 2006-2021, PackardInfo.com All Rights Reserved