Hello and welcome to Packard Motor Car Information! If you're new here, please register for a free account.  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
FAQ's
Main Menu
Recent Forum Topics
Who is Online
61 user(s) are online (38 user(s) are browsing Forums)

Members: 2
Guests: 59

CarFreak, dallas, more...
Helping out...
PackardInfo is a free resource for Packard Owners that is completely supported by user donations. If you can help out, that would be great!

Donate via PayPal
Video Content
Visit PackardInfo.com YouTube Playlist

Donate via PayPal




Charging problem solved? Loose ammeter wire(s).
#1
Just can't stay away
Just can't stay away

Mark Buckley
See User information
Starting eight months ago my 1950 Standard Eight has seen:

Three 6-volt batteries (two replacements, both brand new)
Three generators (two replacements, both completely rebuilt)
Five voltage regulators (four brand new replacements)
Two fan belts (one brand new replacement)

These items were installed by professional mechanics, who thoroughly checked them out at the time of install.

Previous to all this I had the car completely, and professionally, re-wired with original-looking harnesses and cables I bought from by Rhode Island Wiring. Several times over the past few months I've had the car's wiring inspected (by professionals) for poor grounds. Every inspection has turned up nothing.

No matter what I did or had replaced, it seemed, the current flow in the car never seemed adequate to keep up with the demand--particularly if I was driving at night with the headlights on and had to come to a stop. Almost invariably, the car would stall while just sitting there or when it was time to go again. Often, I had to kill the lights to get enough juice to restart.

Yesterday I left the car, again, with a specialty auto electric shop here in Seattle. After some hours I got a call: the car was ready for me to pick up.

On arrival at the shop the mechanic told me the following:

The wires to the ammeter in the instrument cluster had come partially loose. To me, it had looked like the ammeter was working well. But he noticed the wiring to and from the meter was dodgy. He had managed to tighten the wires and this improved the current flow to the point where the charging system was functioning properly. Apparently, all power produced by the system had to pass through the ammeter. If the power could not pass freely through the meter, it would starve the system.

The mechanic went on to say this is one reason why ammeters were replaced by volt meters.

I drove the car for awhile (in daylight) with the lights on, and it generally seemed better.

I have no idea whether this "loose wires at the ammeter" is a common or uncommon problem, but I just thought I'd share it with this group. I've spent well above than $2,000 on all this electrical stuff and I find it ironic that the problem may have been a simple loose wire!

Al the best,

Mark

Posted on: 2012/6/7 14:27
 Top  Print 
 


Re: Charging problem solved? Loose ammeter wire(s).
#2
Home away from home
Home away from home

Tim Cole
See User information
Dear CaptainBristol:

That's a terrible way to go about fixing a car.

Please note the Packard manual is explicit in stating that ammeter wires should be checked for tightness whenever there is a question as to electrical system performance and whenever repairs are made.

Note as well that the gauges originally used anti-shake washers which tend to disappear with service because it takes patience to reinstall them. So check them out at least once per year.

Posted on: 2012/6/7 17:32
 Top  Print 
 


Re: Charging problem solved? Loose ammeter wire(s).
#3
Home away from home
Home away from home

steve-52/200
See User information
Hi I had really good luck with the NAPA 7212 beefy 6 volt fork lift battery ,a POWERGEN 6v positve ground alternator and a pertronix unit for 6v positive ground ,The updated system won't use the ammeter ,but I get instant starts ,The car can sit for a week and start right up, and runs smooth high or low rpm.it doesnt change the appearance of the car .

Posted on: 2012/6/11 23:58
 Top  Print 
 


Re: Charging problem solved? Loose ammeter wire(s).
#4
Quite a regular
Quite a regular

Mike Dowd
See User information
Thank you so much for this post...seemingly little things like this can act like major mystery problems.

Mike

Posted on: 2012/6/12 19:29
 Top  Print 
 








Search
Recent Photos
Photo of the Day
Packard Truck Advert 34
Recent Registry
Website Comments or Questions?? Click Here Copyright 2006-2021, PackardInfo.com All Rights Reserved