Hello and welcome to Packard Motor Car Information! If you're new here, please register for a free account.  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
FAQ's
Main Menu
Recent Forum Topics
Who is Online
47 user(s) are online (34 user(s) are browsing Forums)

Members: 0
Guests: 47

more...
Helping out...
PackardInfo is a free resource for Packard Owners that is completely supported by user donations. If you can help out, that would be great!

Donate via PayPal
Video Content
Visit PackardInfo.com YouTube Playlist

Donate via PayPal



« 1 2 3 (4) 5 6 7 »

Re: Having trouble starting my 400...
#31
Home away from home
Home away from home

JeromeSolberg
See User information
So...were you able to get it started?

Just wondering...

Posted on: 2022/11/11 1:14
 Top  Print 
 


Re: Having trouble starting my 400...
#32
Home away from home
Home away from home

humanpotatohybrid
See User information
Well the fuel line is already disconnected in preparation for fixing those problems, so no I have not. I have the fuel pump fuse pulled actually.

I'm going to put some new plug wires on, at least going to replace the ones a bit messed up.

Posted on: 2022/11/11 8:51
'55 400. Needs aesthetic parts put back on, and electrical system sorted.
'55 Clipper Deluxe. Engine is stuck-ish.
 Top  Print 
 


Re: Having trouble starting my 400...
#33
Home away from home
Home away from home

JWL
See User information
These Rochester carburetors take a special fitting. The fitting has a large diameter and fine thread. It is a special Rochester part and nothing universal I know of is a suitable replacement. There may have been a fine screen filter in back of this fitting. These fine threaded fittings are prone to strip the threads in the carburetors. At one time auto parts houses sold a replacement fitting that would cut new threads. I don't know if they are still available.

The fuel line from the pump has an inverted flare end and nut that screws into the carburetor inlet fitting.

Hope this helps. Howard, can you add anything else?

Posted on: 2022/11/11 13:42
We move toward
And make happen
What occupies our mind... (W. Scherer)
 Top  Print 
 


Re: Having trouble starting my 400...
#34
Home away from home
Home away from home

humanpotatohybrid
See User information
Hmm. There was a barb bitting screwed in there and it seemed fine, but I can check when I get home what's up with that.

Eventually I'm planning to replace the carb with an original anyway.

Posted on: 2022/11/11 14:57
'55 400. Needs aesthetic parts put back on, and electrical system sorted.
'55 Clipper Deluxe. Engine is stuck-ish.
 Top  Print 
 


Re: Having trouble starting my 400...
#35
Home away from home
Home away from home

Packard Don
See User information
Quote:
These Rochester carburetors take a special fitting. The fitting has a large diameter and fine thread. It is a special Rochester part and nothing universal I know of is a suitable replacement.


Although removable, the fitting described is part of the carburetor and typically comes with it. It has a standard thread in the steel line side. If Rochester, the same carburetor is used in my 1965 Cadillacs and I've rebuilt them several times so the only worry is if the special fitting's threads get cross-threaded into the cast aluminum housing or too worn to tighten properly. When that happened on one of my cars, I took it to a local carburetor shop and they put in a stainless Heli-coil and new fitting so as good as new! On mine, it was a flair fitting but on the Packard it might be 1/8" NPT.

Posted on: 2022/11/11 17:02
 Top  Print 
 


Re: Having trouble starting my 400...
#36
Quite a regular
Quite a regular

Redhexagon
See User information
Oh man...somebody incompetent and used to working on Chevrolets has really goofed up your fuel system.

Worry about it later. For now, fill the carburetor bowls with gas manually through the vents. It should run for 30 seconds or so just on the gas that is held in the carburetor. Figure out why it won't start first and attack the fuel line situation later.

Posted on: 2022/11/13 2:37
1955 Patrician. Topaz / White Jade.
 Top  Print 
 


Re: Having trouble starting my 400...
#37
Home away from home
Home away from home

acolds
See User information
fitting for carb inlethttps://www.carburetor-parts.com/fitting-90-43-1) Can't understand fuel system on Packard and Chevy same fuel tank metal line to fuel pump metal line to Rochester or Carter carb. On most cars of this time period pretty easy to redo entire system except for tank which is a little pricey

Posted on: 2022/11/13 17:54
 Top  Print 
Like (1)
 


Re: Having trouble starting my 400...
#38
Home away from home
Home away from home

R H
See User information
AC

That's what I was taking about.

And there is a gasket .

Figured it was put there

Posted on: 2022/11/13 21:37
Riki
 Top  Print 
 


Re: Having trouble starting my 400...
#39
Home away from home
Home away from home

Packard Don
See User information
Quote:
Can't understand fuel system on Packard and Chevy same fuel tank metal line to fuel pump metal line to Rochester or Carter carb.


Technically, and in the parts book this way, it is the line from the pump to the filter. The filter connects directly to the carburetor so no additional lines required and the filter was standard equipment.

Posted on: 2022/11/13 22:19
 Top  Print 
 


Re: Having trouble starting my 400...
#40
Home away from home
Home away from home

humanpotatohybrid
See User information
Got the filter in today and hooked up to the carb. Question is where to use Teflon tape to seal it, if any. Also for the carb fitting it had this slightly oversize copper washer on it with the old setup so I left that on, but it looks too big to seal.

Thinking about taking the tape off the fuel line, and the copper washer off the carb fitting, and using more tape around the carb fitting instead and none on the fuel line. It's cold and dark out so I just left it for now.

Photos below.

Attach file:



jpg  20221117_193320.jpg (880.76 KB)
225076_6376d6b44950f.jpg 4032X3024 px

jpg  20221117_193334.jpg (998.92 KB)
225076_6376d6ed9ac82.jpg 4032X3024 px

jpg  20221117_193329.jpg (1,002.96 KB)
225076_6376d70aa6181.jpg 4032X3024 px

Posted on: 2022/11/17 19:51
'55 400. Needs aesthetic parts put back on, and electrical system sorted.
'55 Clipper Deluxe. Engine is stuck-ish.
 Top  Print 
 




« 1 2 3 (4) 5 6 7 »




Search
Recent Photos
Packard Six (01/24/2023)
Packard Six
Packard Six (01/24/2023)
Packard Six
Packard Six - interior (01/24/2023)
Packard Six - interior
Photo of the Day
1912 Packard 18 Model NE close-coupled, left side
Recent Registry
Website Comments or Questions?? Click Here Copyright 2006-2021, PackardInfo.com All Rights Reserved